Signup/Sign In
Ask Question
Not satisfied by the Answer? Still looking for a better solution?

Fdisk -l shows ext3 file system as HPFS/NTFS

I have an external HDD which I formatted as NTFS partition in Windows. Now, I formatted this HDD in my linux system using the below command.
mkfs.ext3 /dev/sdb1

It was formatted successfully. However, when I run the fdisk -l command, it gives me the system as NTFS/HPFS.
 Device Boot      Start         End      Blocks   Id  System
/dev/sdb1 1 121601 976760001 83 HPFS/NTFS

However, the command df -T /dev/sdb1 was still giving me the file system type as ext3.

Why is it not showing me the system as Linux when I run the fdisk -l command?

1 Answer

The id in the partition table doesn't have to have anything to do with what's actually in the partition. For example, there's no type for an XFS filesystem -- people just use "linux" (83). fdisk will say HPFS/NTFS until you change the partition type:
fdisk /dev/sdb
t 1

Login / Signup to Answer the Question.